(Untitled)

Caixa de diálogo Configuração do Microsoft ODBC for Oracle

A caixa de diálogo Configuração do Microsoft ODBC for Oracle contém os seguintes controlos:

Nome da origem de dados | O nome ou o identificador utilizado por aplicações para chamar ou utilizar esta origem de dados. Os utilizadores podem utilizar qualquer método descritivo para designar uma origem de dados. Este campo é, por predefinição, deixado em branco, mas é necessário.
Descrição | Contém qualificadores descritivos; em branco por predefinição.
Nome de utilizador | O nome de utilizador da origem de dados.
Servidor | O alias da base de dados criado em SQL*Net Easy Configuration ou uma cadeia de ligação. (Para informações sobre a criação de cadeias, consulte Atributos de cadeia de ligação. Para obter descrições de cadeias de ligação a bases de dados pessoais e remotas, consulte o ficheiro de ajuda da Oracle.)
Conversão | Clique em Seleccionar para escolher um conversor de dados carregado; a predefinição é Sem conversor.
Desempenho Tamanho da memória intermédia especifica o tamanho, em bytes, atribuído para receber dados obtidos. O controlador optimiza a obtenção de forma a que uma obtenção do servidor Oracle devolva linhas suficientes para preencher uma memória intermédia com o tamanho especificado. Os valores mais elevados tendem a melhorar o desempenho quando se obtêm muitos dados.

Incluir REMARKS em funções de catálogo especifica que o controlador deve devolver colunas Comentários para o conjunto de resultados SQLColumns . Desmarque esta opção para conseguir um desempenho mais rápido.

Incluir SYNONYMS em SQLColumns especifica que, quando definido como True (1), uma chamada de API SQLColumns() devolve informações de colunas para Tabelas, Vistas e Sinónimos. Este controlador devolve informações de colunas mais rapidamente quando este valor não está definido (ou quando está definido como 0).
Personalização Aplicar padrão DayOfWeek do ODBC define o conjunto de resultados para o formato de um determinado dia da semana. Caso seja seleccionado, especifica que o conjunto de resultados se adequa ao formato de dia da semana do ODBC (Domingo = 1; Sábado = 7). Caso contrário, adequa-se ao formato de dia da semana da Oracle (Segunda-feira = 1; Domingo = 7).

SQLDescribeCol devolve sempre um valor para efeitos de precisão especifica que a chamada de SQLDescribeCol devolverá 130 como precisão quando a Oracle não fornecer essa informação. Alguns tipos de dados numéricos da Oracle não têm uma precisão fixa, como, por exemplo, colunas numéricas processadas e colunas definidas como NUMBER sem uma precisão ou uma escala. Se esta caixa de verificação estiver desmarcada, o controlador devolverá 0 para estes tipos de colunas.

Nota Poderá encontrar informações detalhadas e programáticas sobre este controlador em msdn.microsoft.com. (Abra a MSDN Library Online e, em seguida, a Platform SDK para encontrar o MDAC SDK, que contém um secção intitulada ODBC Drivers.) O controlador de ODBC da Microsoft para Oracle só suporta o SQL*Net 2.3 ou posterior. Para mais informações sobre produtos Oracle, consulte a documentação da Oracle. Poderá encontrar mais informações nas secções Níveis de suporte de software e Suporte a produtos deste ficheiro de ajuda.


.topic 4209
O nome ou o identificador utilizado por aplicações para chamar ou utilizar esta origem de dados. Em branco por predefinição, mas necessário.

.topic 4210
Qualificadores descritivos; em branco por predefinição.

.topic 4201
A quantidade de dados, em bytes, que a aplicação tentará obter de uma só vez.

.topic 4202
Escreva o seu nome de utilizador de base de dados; este é o seu ID de utilizador de base de dados.

.topic 4203
Define o conjunto de resultados para um determinado formato de dia da semana; ODBC ou Oracle.

.topic 4204
Caso seja seleccionado, especifica que o controlador devolve colunas Comentários para o conjunto de resultados SQLColumns. Desmarque esta opção para conseguir um desempenho mais rápido.

.topic 4205
Especifica que o controlador devolve informações de colunas para SYNONYMS.

.topic 4206
Escreva a cadeia de ligação do motor do servidor Oracle a que pretende aceder.

.topic 4207
Clique para escolher um conversor de dados carregado.

.topic 4208
Caso esteja seleccionado, a chamada de SQLDescribeCol devolve 130 para a precisão quando essa informação não for fornecida pela Oracle. Caso contrário, o controlador devolve 0 para estes tipos de colunas.


Atributos de cadeia de ligação

Em vez de uma caixa de diálogo, algumas aplicações poderão necessitar de uma cadeia de ligação que especifique, através de determinados atributos, a forma como um controlador se liga a uma origem de dados. Cada atributo identifica informações específicas necessárias para que o controlador efectue uma ligação bem sucedida. O formato da cadeia de ligação é sempre o seguinte:

"DSN=<nome-origem-dados> ;[SERVER=<valor>] [;PWD=<valor>] [;UID=<valor>] [;<Atributo>=<valor>]"

Nota O controlador de ODBC da Microsoft para Oracle também suporta o argumento CONNECTSTRING da primeira versão (1.x) do controlador.

Tem de especificar o nome da origem de dados, caso não especifique os atributos UID, PWD, SERVER (ou CONNECTSTRING) e DRIVER. No entanto, todos os outros atributos são opcionais. Quando um atributo não for especificado, o atributo especificado no separador DSN da caixa de diálogo Administrador da origem de dados de ODBC será a predefinição.

Os atributos de cadeia de ligação são descritos na tabela seguinte.

Atributo | Descrição | Valor predefinido
DSN O nome da origem de dados, listado no separador DSN de utilizador ou DSN de sistema da caixa de diálogo Administrador da origem de dados de ODBC. ""
PWD A palavra-passe do servidor Oracle a que pretende aceder. Este controlador suporta o limite de 30 caracteres definido pela Oracle e tem as mesma limitações colocadas pela Oracle a palavras-passe. ""
SERVER A cadeia do servidor Oracle a que pretende aceder.

Esta cadeia pode ser um alias de base de dados da Oracle, uma entrada do ficheiro Tnsnames.ora ou um alias que será mapeado para o servidor correcto através do servidor de nomes da Oracle.

Um alias de base de dados pode ser definido utilizando o SQL*Net Fast Configuration da Oracle (ou o Net8 Easy Configuration para bases de dados Oracle8). Para mais informações sobre a ligação a uma base de dados Oracle, consulte a documentação da Oracle.

 ""
UID O nome de utilizador do servidor Oracle. Este atributo poderá não ser opcional; determinadas bases de dados e tabelas poderão necessitar deste atributo por motivos de segurança.

Para indicar a autenticação do sistema operativo da Oracle, utilize "UID=/;".

""
BUFFERSIZE O tamanho ideal da memória intermédia para obter colunas.

O controlador optimiza a obtenção de forma a que uma obtenção do servidor Oracle devolva linhas suficientes para preencher uma memória intermédia com este tamanho. Os valores mais elevados tendem a melhorar o desempenho se obtiver muitos dados.

 65535
SYNONYMCOLUMNS | Quando este valor é true (1), uma chamada de API SQLColumns devolve informações de coluna para Tabelas, Vistas e Sinónimos. Caso contrário, SQLColumns devolve apenas colunas para Tabelas e Vistas. Para conseguir um desempenho mais rápido, não defina este valor. | 1
REMARKS | Quando este valor for True (1), o controlador devolverá colunas Comentários para o conjunto de resultados SQLColumns . Para conseguir um desempenho mais rápido, não defina este valor. | 0
StdDayOfWeek | Aplica o padrão de ODBC à escalar DAYOFWEEK. Esta é a predefinição; os utilizadores que necessitem da versão localizada podem alterar o comportamento de forma a utilizar o que a Oracle devolver. | 1

Nota Os valores de atributo podem ser sensíveis a maiúsculas e minúsculas.

Exemplos

A seguinte cadeia de ligação liga à origem de dados Empregados utilizando o servidor Oracle feira.popular e o utilizador Oracle sofia:

"DSN=Empregados;UID=sofia;PWD=secret;SERVER=feira.popular"

A seguinte cadeia de ligação liga à origem de dados Pagamentos utilizando a autenticação de sistema operativo da Oracle e o servidor Oracle moola:

"DSN=Pagamentos;UID=/;PWD=;SERVER=moola"


Caixa de diálogo Ligação do Microsoft ODBC for Oracle

A caixa de diálogo Ligação do Microsoft ODBC for Oracle contém os seguintes controlos:

Nome de utilizador | O nome utilizado para ligar à base de dados Oracle.
Palavra-passe | A palavra-passe utilizada para ligar à base de dados Oracle, com as mesma limitações impostas a palavras-passe pela Oracle.
Servidor | Escreva um alias de base de dados da Oracle, uma entrada do ficheiro Tnsnames.ora ou um alias que será mapeado para o servidor correcto através do servidor de nomes da Oracle. Poderá encontrar mais informações sobre a ligação a uma base de dados Oracle em msdn.microsoft.com. (Abra a MSDN Library Online e, em seguida, a Platform SDK para encontrar o MDAC SDK, que contém uma secção intitulada ODBC Drivers.) Poderá encontrar informações sobre o ficheiro Tnsnames.ora na documentação da Oracle.


Suporte a produtos

Poderá encontrar informações detalhadas e programáticas sobre este controlador em msdn.microsoft.com. (Abra a MSDN Library Online e, em seguida, a Platform SDK para encontrar o MDAC SDK, que contém um secção intitulada ODBC Drivers.)

A Oracle Corporation fornece documentação de ajuda específica para a configuração e a utilização do software cliente da Oracle.


Níveis de suporte de software

O controlador de ODBC da Microsoft para Oracle suporta:

  • Microsoft Windows 95/98, Microsoft Windows NT 4.0 ou Windows 2000

  • Oracle Call Interface 7 (OCI7)

  • SQL*Net 2.3 ou posterior

  • ODBC 2.x e anterior (Pode ser instalada a versão mais recente de ODBC, mas não poderão ser utilizadas todas as funções).


SQLColumns

Cria um conjunto de resultados para uma tabela, que se trata da lista de colunas da tabela ou das tabelas especificadas. Quando pedir colunas para um sinónimo PUBLIC, terá de ter definido o atributo de ligação SYNONYMCOLUMNS e de ter especificado uma cadeia vazia como argumento szTableOwner. Quando devolver colunas para sinónimos PUBLIC, o controlador define a coluna TABLE NAME como uma cadeia vazia. O conjunto de resultados contém uma coluna adicional, ORDINAL POSITION, no final de cada linha. Este valor é a posição ordinal da coluna na tabela.